
Correct reflow problems with the Content 

panel 
Use the Content panel to correct reflow problems in a PDF that can’t be corrected by using 

the Reading Order tool. Because you can damage a PDF by editing content objects, make 
sure that you’re familiar with PDF structure before you change anything. For comprehensive 

information about PDF structure, see the PDF Reference Sixth Edition: Adobe Portable 
Document Format Version 1.7, on the PDF reference page (English only) of the Adobe website. 

The Content panel provides a hierarchical view of the objects that make up a PDF, including 

the PDF object itself. Each document includes one or more pages, a set of annotations (such 

as comments and links), and the content objects for the page. The content objects consist of 

containers, text, paths, and images. Objects are listed in the order in which they appear on 

the page, like tags in the logical structure tree. However, PDFs don’t require tags for you to 
view or change the object structure. 

1. Choose the hamburger   Menu (Windows), or the View menu 
(macOS) > Show/Hide > Navigation Panels > Content. 

2. Expand the document name to view pages and objects. 

3. Move a container or object by selecting it and doing one of the following: 

  

• Drag it to the location that you want. 

• Choose Cut from the Options menu, select the tag above the location you 
want to paste the cut tag, and choose Paste from the Options menu. 

  

Note:  

Container elements can’t be pasted directly to page elements. To move a container 
to another page, cut the container you want to move. Then select a container on 

the page that you want to move the container to and choose Paste from the 

Options menu. Then, drag the container out one level to the location that you 
want.   

Content panel options 

In the Content panel, use the Options menu or right-click an object to choose from the 
following options: 

New Container 

Adds a container object at the end of the selected page or container. 
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Edit Container Dictionary 

Specifies the dictionary for the container. Errors in this dialog box may damage the PDF. 
Available only for containers that include dictionaries. 

Cut 

Cuts and copies the selected object (not the related page content). 

Paste 

Pastes content directly below the selected object at the same hierarchical level. 

Paste Child 

Pastes content into the selected object as a child content item. 

Delete 

Removes the object (not the related page content) from the document. 

Find Content From Selection 

Searches for the object in the Content panel that contains the object selected in the 

document pane. 

Find 

Searches for unmarked (untagged) artifacts, content, comments, and links. Options allow you 

to search the page or document, and to add tags to found items. 

Create Artifact 

Defines selected objects as artifacts. Artifacts are not read by a screen reader or by the 
Read Out Loud feature. Page numbers, headers, and footers are often best tagged as 
artifacts. 

Show In Tags Panel 

Switches automatically to the Tags panel, and selects the tag corresponding to the content 

element. 

Remove Artifact 

Removes the artifact definition from the selected object. 

Highlight Content 

When selected, highlights appear in the document pane around content that relates to a 
selected object in the Content panel. 

Show Metadata 

Allows viewing and editing of image or object metadata. 



Properties 

Opens the Touch Up Properties dialog box. 

About the Tags panel 

The Tags panel allows you to view and edit tags in the logical structure tree, or tags tree, of a 

PDF. In the Tags panel, tags appear in a hierarchical order that indicates the reading 

sequence of the document. The first item in this structure is the Tags root. All other items are 
tags and are children of the Tags root. Tags use coded element types that appear in angle 

brackets (< >). Each element, including structural elements such as sections and articles, 

appears in the logical structure ordered by type. It's followed by a title and the element’s 

content or a description of the content. Structural elements are typically listed as containers 
(parent tags). They include several smaller elements (child tags) within them. 

Note:  

For more information on logical structures, see the PDF Reference Sixth Edition: Adobe 

Portable Document Format Version 1.7, on the PDF reference page (English only) of the 
Adobe website. 

Though you can correct most tagging issues by using the Reading Order tool, you must use 

the Tags panel to address detailed tagging of tables and substructure items, such as 

paragraphs, lists, and sections that require multiple languages. Add tags manually to a 

document in the Tags panel only as a last resort. First consider using the Add Tags To 
Document command. 

View tags in the Tags panel 

1. Choose the hamburger   Menu (Windows), or the View menu 
(macOS) > Show/Hide > Navigation Panels > Tags. 

2. Do one of the following: 

  

• Expand the tag for the section that you want. 

• Ctrl-click the plus sign (Windows) or Option-click the triangle (macOS) next 
to the Tags root to show all tags in the logical structure tree. 
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Edit tags with the Tags panel 

You can edit a tag title, change a tag location, or change the tag type for an element. All page 
content must be tagged, marked as an artifact, or removed from the logical structure tree. 

Edit a tag title 

1. In the Tags panel, expand the section of the logical structure that you want to edit. 

2. To edit the title, Select the tag, choose Properties from the Options menu, enter 
text in the Title box, and click Close. 

Move a tag 

1. In the Tags panel, expand the Tags root to view all tags. 

2. Select the Tag icon of the element that you want to move. 

3. Do one of the following: 

  

• Drag the tag to the location that you want. As you drag, a line appears at 
viable locations. 

• Choose Cut from the Options menu, and select the tag that appears above 

the location you want to paste the cut tag. From the Options menu, choose 

Paste to move the tag to the same level as the selected tag. Or choose Paste 
Child to move the tag within the selected tag. 

Change the element type 

1. In the Tags panel, expand the section of the logical structure that you want to 
change. 

2. Select an element and choose Properties from the Options menu. 

3. Choose a new element type from the Type menu, and then click Close. 

Tags panel options 

In the Tags panel, use the Options menu or right-click a tag in the logical structure tree to 
choose from the following options: 

New Tag 

Creates a tag in the logical structure tree after the currently selected item. Specify type and 
title of the new tag. 



Cut 

Removes the selected tag from its current location and puts it on the clipboard. 

Paste 

Places the tag that’s on the clipboard into the location specified, replacing the selected tag. 

Paste Child 

Places the tag that’s on the clipboard into the location specified, as a child of the selected tag. 

Delete Tag 

Removes the selected tag. 

Find Tag From Selection 

Searches for the tag in the Tags panel that contains the text or object selected in the 
document pane. 

Create Tag From Selection 

Creates a tag in the logical structure tree after the item selected in the document pane. 

Specify type and title of the new tag. 

Find 

Searches for artifacts, OCR suspects, and unmarked (untagged) content, comments, links, 

and annotations. Options allow you to search the page or document and add tags to found 

items. 

Change Tag To Artifact 

Changes selected tags to artifacts and removes the tagged content from the structure tree. 

Copy Contents To Clipboard 

Copies all content contained within the selected tags. 

Edit Class Map 

Allows you to add, change, and delete the class map, or style dictionary, for the document. 
Class maps store attributes that are associated with each element. 

Edit Role Map 

Allows you to add, change, and delete role maps for the document. Role maps allow each 

document to contain a uniquely defined tag set. By mapping these custom tags to predefined 
tags in Acrobat, custom tags are easier to identify and edit. 

Tag Annotations 



When selected, all new comments and form fields are added to the tag tree after the selected 
tag element. Existing comments and form fields aren’t added to the tag tree. Highlight and 

Underline comments are automatically associated and tagged with the text that they 
annotate and don’t require this option. 

Document Is Tagged PDF 

Flags the PDF as a tagged document. Deselect to remove the flag. 

Note:  

This option doesn’t necessarily indicate that the PDF conforms to PDF guidelines and should 

be used judiciously. 

Highlight Content 

When selected, causes highlights to appear around content in the document pane when you 
select the related tag in the Tags panel. 

Show Metadata 

Opens a read-only dialog box that contains reference information about the selected tag. 

Properties 

Opens the Touch Up Properties dialog box. 

Add alternate text and supplementary 

information to tags 

Some tagged PDFs might not contain all the information necessary to make the document 

contents fully accessible. For example, if you want to make a document available to a screen 

reader, the PDF should contain alternate text for figures. It should also include language 
properties for portions of the text that use a language that is different from the default 

language for the document and expansion text for abbreviations. Designating the appropriate 

language for different text elements ensures that the correct characters are used when you 

repurpose the document and that it's spell-checked with the correct dictionary. 

You can add alternate text and multiple languages to a tag from the Tags panel. (If only one 
language is required, choose the language with File > Properties instead.) You can also add 
alternate text by using the Reading Order tool. 

Note:  

Keep alternate text descriptions as concise as possible. 



Add alternate text to links 

Screen readers can read the URLs of web links out loud, but adding meaningful alternate text 
to links can help users immensely. For example, by adding the alternate text you can have a 

screen reader tell a user to “go to the Acrobat accessibility page of adobe.com” rather than 
“go to http://www.adobe.com/products/acrobat/solutionsacc.html.” 

You add alternate text to the <Link> tag of a link. 

Note:  

Add alternate text only to tags that don’t have child tags. Adding alternate text to a parent tag 
prevents a screen reader from reading any of that tag’s child tags. 

1. In the tag tree, select the <Link> tag for the link, and select Properties from the 

Options menu. 

2. In the Touch Up Properties dialog box, select the Tag panel. 

3. Type alternate text for the link, and click Close. 

Add alternate text for a figure 
1. Choose the hamburger   Menu (Windows), or the View menu 

(macOS) > Show/Hide > Navigation Panels > Tags. 

2. Expand the logical structure tree to find and select the <Figure> tag element for 

the image. 

  

Note:  

To find a tag more easily, use the Reading Order tool to select the figure or text 

near the figure in the document pane. Then, choose Find Tag From Selection from 
the Options menu in the Tags panel. 

3. Choose Highlight Content from the Options menu in the Tags panel to see a 
highlighted area in the document that corresponds to the tag. 

4. Choose Properties from the Options menu in the Tags panel. 

5. In the Touch Up Properties dialog box, click the Tag panel. 

6. For Alternate Text, type text that describes the figure. 

Add alternate text for an abbreviated term 

1. In the Tags panel, locate the abbreviated term by doing one of the following: 

  



• Expand the tag tree as needed to see the elements that contain the 
abbreviation. 

• Use the Touch Up Text tool or the Select tool to select the abbreviation in 
the document, and then choose Find Tag From Selection from the Options 
menu to locate the text in the tag tree. 

2. Select the tag for that element, and choose Properties from the Options menu. 

  

Note:  

If the abbreviation includes additional text, cut the additional text and place it in a 

new <Span> child tag within the same <Span> parent tag. 

3. In the Touch Up Properties dialog box, select the Tag panel. 

4. For Alternate Text, type the unabbreviated version of the term. 

5. Click Close. 

Create a new child tag 

1. In the Tags panel, select the parent node (the icon at the same level at which you 

want to create a child tag) in the Tags tree for which you want to create a child tag. 

2. Choose New Tag from the Options menu. 

3. Select the appropriate tag type from the Type pop-up menu, or type a custom tag 
type, name the tag (optional), and then click OK. 

Add tags to comments 

When you tag a PDF that includes comments, the comments are tagged as well. However, if 

you add comments to a PDF that’s already tagged, your comments are untagged unless you 
enable comment tagging first. 

Note:  

To Enable comment tagging in a PDF, in the Tags panel, choose Tag Annotations from the 

Options menu. Comments or markups that you add to the PDF are tagged automatically. 



If a document contains untagged comments, find them in the logical structure tree and tag 
them using the Find command in the Tags panel. 

1. In the Tags panel, choose Find from the Options menu. 

2. In the Find Element dialog box, choose Unmarked Comments from the Find pop-
up menu, and click Find. 

3. When the comment type appears in the Type field (for example, Text), click Tag 
Element, choose Annotation from the Type pop-up menu in the New Tag dialog 
box, and then click OK. 

4. In the Find Element dialog box, click Find Next to locate and tag all comments, and 
then click Close. 

Correct table tags with the Tags panel 

Use the Reading Order tool to make sure that tables are tagged correctly. To fit figures and 

text within the table cells, re-create the table in the authoring application before converting it 
to an accessible PDF. Adding tags on a cell level in Acrobat is a labor-intensive procedure. 

Before you change any table elements, use the Reading Order tool to determine that the 
table is tagged correctly. 

Check table elements 

1. In the Tags panel, expand the tags root to view a table tag. 

2. Select the table tag <Table> and verify that it contains one of the following 

elements: 

  

• Table Rows, each of which contains Table Header <TH> or Table 

Data<TD> cells. 

• <THead>, <TBody>, and <TFoot> sections, each of which containsTable 

Rows. (The Table Rows contain <TH> cells, <TD> cells, or both.) 

3. Do one or more of the following: 

  

• If the tag for the table doesn’t contain these elements, but rows, columns, 
and cells appear in the table in the document pane, use the Reading 
Order tool to select and define the table or individual cells. 



• If the table contains rows that span two or more columns, set ColSpan and 
RowSpan attributes for these rows in the tag structure. 

• Re-create the table in the authoring application, and then convert it to a 
tagged PDF. 

Set ColSpan and RowSpan attributes 

1. In the Tags panel, select a <TD> or <TH> element. 

2. Choose Properties from the Options menu. 

3. In the Touch Up Properties dialog box, click the Tag panel, and then click Edit 
Attribute Objects. 

4. Select Attribute Objects, and then select New Item to create an Attribute Object 
Dictionary. 

5. Expand the new dictionary, select the Layout attribute, and then click Change Item. 

6. Change the Layout value to Table. 

7. Select the Attribute Object Dictionary, and click New Item. 

8. In the Add Key And Value dialog box, type ColSpan or RowSpan in the Key box. 

Enter the number of columns or rows in the Value box, choose Integer from the 
Value Type pop-up menu, and select OK. 

Standard PDF tags 

This section describes the standard tag types that apply to tagged PDFs. These standard tags 
provide assistive software and devices with semantic and structural elements to use to 
interpret document structure and present content in a useful manner. 

The PDF tags architecture is extensible, so any PDF document can contain any tag set that an 

authoring application decides to use. For example, a PDF can have XML tags that came in 

from an XML schema. Custom tags that you define (such as tag names generated from 

paragraph styles of an authoring application) need a role map. The role map matches each 

custom tag to a standard tag here. When assistive software encounters a custom tag, the 

software can check this role map, and properly interpret the tags. Tagging PDFs by using one 
of the methods described here generally produces a correct role map for the document. 

Note:  

You can view and edit the role map of a PDF by choosing Options > Edit Role Map in the Tags 
panel. 



The standard Adobe element tag types are available in the New Tag dialog box. They are also 
available in the Touch Up Properties dialog box in Acrobat Pro. Adobe strongly encourages 

using these tag types because they provide the best results when tagged content is converted 

to a different format. These formats include HTML, Microsoft Word, or an accessible text 
format for use by other assistive technologies. 

Block-level elements are page elements that consist of text laid out in paragraph-like forms. 
Block-level elements are part of a document’s logical structure. Such elements are further 

classified as container elements, heading and paragraph elements, label and list elements, 
special text elements, and table elements. 

Container elements 

Container elements are the highest level of element and provide hierarchical grouping for 
other block-level elements. 

Document 

Document element. The root element of a document’s tag tree. 

Part 

Part element. A large division of a document; may group smaller units of content together, 

such as division elements, article elements, or section elements. 

Div 

Division element. A generic block-level element or group of block-level elements. 

Art 

Article element. A self-contained body of text considered to be a single narrative. 

Sect 

Section element. A general container element type, comparable to Division (DIV 

Class=“Sect”) in HTML, which is usually a component of a part element or an article 

element. 

Heading and paragraph elements 

Heading and paragraph elements are paragraph-like, block-level elements that include 

specific level heading and generic paragraph (P) tags. A heading (H) element should appear as 

the first child of any higher-level division. Six levels of headings (H1 to H6) are available for 

applications that don’t hierarchically nest sections. 

Label and list elements 

Label and list elements are block-level elements used for structuring lists. 
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L 

List element. Any sequence of items of similar meaning or other relevance; immediate child 
elements should be list item elements. 

LI 

List item element. Any one member of a list; may have a label element (optional) and a list 
body element (required) as a child. 

LBL 

Label element. A bullet, name, or number that identifies and distinguishes an element from 
others in the same list. 

LBody 

List item body element. The descriptive content of a list item. 

Special text elements 

Special text elements identify text that isn’t used as a generic paragraph (P). 

BlockQuote 

Block quote element. One or more paragraphs of text attributed to someone other than the 

author of the immediate surrounding text. 

Caption 

Caption element. A brief portion of text that describes a table or a figure. 

Index 

Index element. A sequence of entries that contain identifying text and reference elements 
that point out the occurrence of the text in the main body of the document. 

TOC 

Table of contents element. An element that contains a structured list of items and labels 
identifying those items; has its own discrete hierarchy. 

TOCI 

Table of contents item element. An item contained in a list associated with a table of contents 
element. 

Table elements 

Table elements are special elements for structuring tables. 

Table 



Table element. A 2D arrangement of data or text cells that contains table row elements as 
child elements. It may have a caption element as its first or last child element. 

TR 

Table row element. One row of headings or data in a table; may contain table header cell 
elements and table data cell elements. 

TD 

Table data cell element. A table cell that contains nonheader data. 

TH 

Table header cell element. A table cell that contains header text or data describing one or 

more rows or columns of a table. 

Inline-level elements 

Inline-level elements identify a span of text that has specific formatting or behavior. They are 

differentiated from block-level elements. Inline-level elements may be contained in or 
contain block-level elements. 

BibEntry 

Bibliography entry element. A description of where some cited information may be found. 

Quote 

Quote entry element. An inline portion of text that is attributed to someone other than the 

author of the surrounding text. It's different from a block quote, which is a whole paragraph 
or multiple paragraphs, as opposed to inline text. 

Span 

Span entry element. Any inline segment of text; commonly used to delimit text that is 
associated with a set of styling properties. 

Special inline-level elements 

Similar to inline-level elements, special inline-level elements describe an inline portion of text 
that has special formatting or behavior. 

Code 

Code entry element. Computer program text embedded within a document. 

Figure 

Figure entry element. A graphic associated with the text. 

Form 



Form entry element. A PDF form annotation that can be or has been filled out. 

Formula 

Formula entry element. A mathematical formula. 

Link 

Link entry element. A hyperlink that is embedded within a document. The target can be in the 
same document, in another PDF document, or on a website. 

Note 

Note entry element. Explanatory text or documentation, such as a footnote or endnote, that 

is referred to in the main body of text. 

Reference 

Reference entry element. A citation to text or data that is found elsewhere in the document. 

 


