
Overview 

You can use Acrobat to make PDFs meet the common accessibility standards, such as Web 
Content Accessibility Guidelines (WCAG) 2.0 and PDF/UA (Universal Access, or ISO 14289). 
Acrobat provides the following accessibility tools: 

• Prepare for accessibility: A predefined action automates many tasks, checks 

accessibility, and provides instructions for items that require manual fixes. Quickly 
find and fix problem areas. 

• Accessibility check: It verifies whether the document conforms to accessibility 
standards, such as PDF/UA and WCAG 2.0. 

• Accessibility report: It summarizes the findings of the accessibility check. It contains 

links to tools and documentation that assist in fixing problems. 

• Reading options: It includes settings for the available reading options.  
 

• Reading order: You can use the Reading Order tool to examine the structure, reading 
order, and contents of a PDF. 

• Save as accessible text: It allows you to read the saved text file in a word-processing 

application. It also enables you to emulate the end-user experience of readers who 
use a braille printer to read the document. 

Check accessibility of PDFs (Acrobat Pro) 

You can use the Prepare for accessibility tool to check and make a PDF accessible. It prompts 

you to address accessibility issues, such as a missing document description or title. It looks 
for common elements that need further action, such as scanned text, form fields, tables, and 

images. You can run a Prepare for accessibility 
action on all PDFs except dynamic forms (XFA documents) or portfolios. 

1. Open the PDF and then from the All tools menu on the left, select View more and 
then select Prepare for accessibility. 

Or, from the top menu, select See all tools. Then, scroll down to Prepare > Prepare 
for accessibility and select Open. 

It displays the Prepare for accessibility page with a list of available actions 

displayed on the left panel. 

2. From the left panel, select Accessibility check. 

The right-hand pane changes to display each task included in the Make Accessible 
action, as well as the instructions to execute the action. 

3. From the Accessibility Checker Options dialog, select the options as required and 
then select Start Checking. 
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4. Once the check is complete, it displays a panel on the right that lists the 
accessibility issues. Select each issue type drop-down to view the details and make 
fixes, as suggested. 

  

Since the Accessibility Check feature does not distinguish between essential and 

nonessential content types, some reported issues may not affect readability. We 
suggest that you review all issues to determine the ones that need correction. 

The report displays one of the following statuses for each rule check: 

• Passed: The item is accessible. 

• Skipped By User: Rule was not checked because it wasn't selected in 

the Accessibility Checker Options dialog box. 

• Needs Manual Check: The Full Check/Accessibility Check feature couldn't 

check the item automatically. Verify the item manually. 

• Failed: The item didn't pass the accessibility check. 

5. To view a complete report of the check, from the left panel, select Accessibility 
report. 

It displays a detailed report in the right panel. 

Fix accessibility issues (Acrobat Pro) 

To fix a failed check after running the Prepare for accessibility check, right-click (Windows) or 

Ctrl-click (Mac OS) the item in the Accessibility Checker panel and select one of the following 
options from the context menu: 

• Fix: Acrobat either fixes the item automatically or displays a dialog box prompting you 
to fix the item manually. 

• Skip Rule: Deselects this option in the Accessibility Checker Options dialog box for 
future checks of this document, and change the item status to Skipped. 

• Explain: Opens the online Help where you can get more details about the accessibility 
issue. 

• Check Again: Runs the checker again on all items. Choose this option after modifying 
one or more items. 

• Show Report: Displays a report with links to tips on how to repair failed checks. 

• Options: Opens the Accessibility Checker Options dialog box, so you can select which 
checks are performed. 

Accessibility issues 

Document 
PREVENT SECURITY SETTINGS FROM INTERFERING WITH SCREEN READERS 



A document author can specify that no part of an accessible PDF is to be copied, printed, 
extracted, commented on, or edited. This setting could interfere with a screen reader's ability 

to read the document because screen readers must be able to copy or extract the document's 
text to convert it to speech. 

This flag reports whether it's necessary to turn on the security settings that allow 
accessibility. 

To fix the rule automatically, go to All tools > Prepare for accessibility > Accessibility 
check and then ensure that the Accessibility permission flat is set checkbox is selected 

before running the check. Then, from the Accessibility Checker report, right-click 
the Accessibility permission flag and select Fix. 

To manually fix the accessibility permissions: 

1. Select the hamburger menu  (Windows) or the File menu (macOS) > Document 
properties. 

2. In the Document properties dialog: 

1. Select the Security tab. 

2. From the Security Method drop-down, select No Security. 

3. Select OK. 

If your assistive technology product is registered with Adobe as a Trusted Agent, you can read 
PDFs that might be inaccessible to another assistive technology product. Acrobat recognizes 

when a screen reader or other product is a Trusted Agent and overrides security settings that 

would typically limit access to the content for accessibility purposes. However, the security 

settings remain in effect for all other purposes, such as to prevent printing, copying, 
extracting, commenting, or editing text. 

Note:  

See the related WCAG section: 1.1.1 Non-text Content. (A), 4.1.2 Name, role, value 

IMAGE-ONLY PDF 

Reports whether the document contains non-text content that is not accessible. If the 

document appears to contain text, but doesn't contain fonts, it could be an image-only PDF 
file. 

To fix the rule automatically, go to All tools > Prepare for accessibility > Accessibility 

check and then ensure that the Document is not-image only PDF checkbox is deselected 
before running the check. 

To fix this rule check manually, use OCR to recognize text in scanned images: 

1. From the All tools menu, select Scan & OCR. 
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2. From the Scan & OCR panel, under Recognize Text, select In this file. 

3. From the Pages dialog, select the pages you want to process, the document 
language, and then select Recognize text. 

Note:  

See the related WCAG section: 1.1.1. Non-text content (A) 

TAGGED PDF 

If this rule check fails, the document isn't tagged to specify the correct reading order. 

To fix the item automatically, go to All tools > Prepare for accessibility > Accessibility 

check and then ensure that the Document is tagged PDF checkbox is selected before 

running the check. Acrobat automatically adds tags to the PDF. 

To specify tags manually, do one of the following: 

• Enable tagging in the source application and re-create the PDF. 

• Select All tools > Prepare for accessibility > Autotag document. The Add Tags 

Report appears in the navigation pane if there are any issues. The report lists potential 

problems by page, provides a navigational link to each problem, and provides 
suggestions for fixing them. 

• Select All tools > Prepare for Accessibility > Reading order and create the tags tree. 
For more information, see Reading Order. 

• Open the Tags panel and create the tags tree manually. To display the Tags panel, 

select the hamburger menu  (Windows) > View or select the View menu (macOS), 

and then select Show/Hide > Side panels > Accessibility tags. For more information, 
see the Edit document structure with the Content and Tags panel. 

Note:  

See the related WCAG section: 1.3.1 Info and Relationships, 1.3.2, 2.4.1, 2.4.4, 2.4.5, 2.4.6, 
3.1.2, 3.3.2, 4.1.2 Name, role, value 

LOGICAL READING ORDER 

Verify this rule check manually. Make sure that the reading order displayed in the Tags panel 
coincides with the logical reading order of the document. 

DOCUMENT LANGUAGE 

Setting the document language in a PDF enables some screen readers to switch to the 

appropriate language. This check determines whether the primary text language for the PDF 
is specified. If the check fails, set the language. 
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To set the language automatically, select Primary Language in the Accessibility Checker tab 

and then choose Fix from the Options  menu. Choose a language in the Set Reading 
Language dialog box, and then select OK. 

To set the language manually, do one of the following: 

• Choose the hamburger menu  (Windows) or the File menu 

(macOS) > Properties > Advanced, and then select a language from the drop-down 
list in the Reading Options section. (If the language doesn't appear in the drop-down 

list, you can enter the ISO 639 code for the language in the Language field.) This 
setting applies the primary language for the entire PDF. 

• Set the language for all text in a subtree of the tags tree. Open the Tags  panel. 

Expand the Tags root and select an element. Then choose Properties from 

the Options  menu. Choose a language from the Language drop-down list. (To 

display the Tags panel, select the hamburger menu  (Windows) > View or select 

the View menu (macOS), and then select Show/Hide > Side panels > Accessibility 
tags.) 

• Set the language for a block of text by selecting the text element or container element 

in the Content  panel. Then, right-click (Windows) or Ctrl-click (macOS) the text, 

choose Properties from the context menu, and choose a language from the Language 
drop-down list. (To display the Content panel, select the hamburger 

menu  (Windows) > View or select the View menu (macOS), and then 
select Show/Hide > Side panels > Content.) 

Note:  

See the related WCAG section: Language of Page (Level A) 

TITLE 

Reports whether there is a title in the Acrobat application title bar. 

To fix the title automatically, select Title in the Accessibility Checker tab, and choose Fix 

from the Options  menu. Enter the document title in the Description dialog box 
(deselect Leave As Is, if necessary). 

To fix the title manually: 

1. Select the hamburger menu  (Windows) or the File menu (macOS) > Document 
properties. 

2. In the dialog that opens, under Description, enter a title in the Title text box. 

3. Select Initial View and then from the Show drop-down, select Document Title. 

4. Select OK. 
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Note:  

See the related WCAG section: 2.4 Page Titled (Level A) 

BOOKMARKS 

This check fails when the document has 21 or more pages, but doesn't have bookmarks that 
parallel the document structure. 

To add bookmarks to the document, select Bookmarks on the Accessibility Checker panel, 

and choose Fix from the Options  menu. In the Structure Elements dialog box, select the 

elements that you want to use as bookmarks, and click OK. (You can also access 

the Structure Elements dialog box by clicking the Options menu on the Bookmark tab and 

selecting the New Bookmarks From Structure command.) 

Note:  

See the related WCAG sections: 2.4.1 Bypass Blocks (Level A), 2.4.5 Multiple Ways (Level AA) 

COLOR CONTRAST 

When this check fails, it's possible that the document contains content that isn't accessible to 
people who are color-blind. 

To fix this issue, make sure that the document's content adheres to the guidelines outlined 
in WCAG section 1.4.3. Or, include a recommendation that the PDF viewer use high-contrast 
colors: 

1. Select the hamburger menu  (Windows) or the Acrobat menu (macOS) 
> Preferences.  

2. In the dialog that opens, from the left panel, select Accessibility. 

3. Select Replace Document Colors and then select Use High-Contrast Colors. From 

the High-contrast color combination, choose the color combination that you want 
and then select OK. 

Page content 
TAGGED CONTENT 

This check reports whether all content in the document is tagged. Make sure that all content 

in the document is either included in the Tags tree, or marked as an artifact. 

Do one of the following to fix this rule check: 

• Open the Content  panel and right-click (Windows) or Ctrl-click (macOS) the 

content that you want to mark as an artifact. Then, select Create Artifact from the 
context menu. (To display the Content tab, select the hamburger menu  (Windows) 
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> View or select the View menu (macOS), and then select Show/Hide > Side 
panels > Content.) 

• Tag the content by choosing All tools > Prepare for accessibility > Reading order. 
Select the content, and then apply tags as necessary. 

• Assign tags using the Tags  panel. Right-click (Windows) or Ctrl-click (Mac OS) the 

element in the Tags tree, and choose Create Tag From Selection. Items such as 
comments, links, and annotations don't always appear in the Tags tree. To find these 

items, choose Find from the Options menu. (To display the Tags panel, select the 

hamburger menu  (Windows) > View or select the View menu (macOS), and then 
select Show/Hide > Side panels > Accessibility tags.) 

Note:  

See the related WCAG sections: 1.1.1 Non-text content (A), 1.3.1 Info and Relationships (Level 
A), 1.3.2 Meaningful Sequence (Level A), 2.4.4 Link Purpose (In Context) (Level A), 3.1.2 
Language of Parts (Level AA), 4.1.2 Name, role, value 

TAGGED ANNOTATIONS 

This rule checks whether all annotations are tagged. Make sure that annotations such as 

comments and editorial marks (such as insert and highlight) are either included in 
the Tags tree or marked as artifacts. 

• Open the Content  panel , and right-click (Windows) or Ctrl-click (Mac OS) the 

content that you want to mark as an artifact. Then, select Create Artifact from the 

context menu. (To display the Content panel, choose select the hamburger 

menu  (Windows) > View or select the View menu (macOS), and then 
select Show/Hide > Side Panels > Content). 

• To tag the content, select All tools > Prepare for accessibility > Reading order. Then 
select the content and apply the tags as necessary. 

• Assign tags using the Tags  panel. (To display the Tags panel, choose select the 

hamburger menu  (Windows) > View or select the View menu (macOS), and then 
select Show/Hide 
> Side Panels > Accessibility tags). 

To have Acrobat assign tags automatically to annotations as they're created, choose Autotag 

document from the Options ( . . . ) menu on the Tags panel. 

Note:  

See the related WCAG section: 1.3.1 Info and Relationships (Level A), 4.1.2 Name, role, value 

TAB ORDER 
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Because tabs are often used to navigate a PDF, it's necessary that the tab order parallels the 
document structure. 

To fix the tab order automatically, select Tab Order on the Accessibility Checker panel, and 

choose Fix from the Options  menu. 

To manually fix the tab order for links, form fields, comments, and other annotations: 

1. Click the Page Thumbnails panel on the navigation pane. 

2. Click a page thumbnail, and then choose Page Properties from 

the Options  menu. 

3. In the Page Properties dialog box, choose Tab Order. Then, select Use Document 

Structure, and select OK. 

4. Repeat these steps for all thumbnails in the document. 

Note:  

See the related WCAG section: 2.4.3, Focus Order (Level A) 

CHARACTER ENCODING 

Specifying the encoding helps PDF viewers' present users with readable text. However, some 
character-encoding issues aren't repairable within Acrobat. 

To ensure proper encoding, do the following: 

• Verify that the necessary fonts are installed on your system. 

• Use a different font (preferably OpenType) in the original document, and then re-
create the PDF. 

• Re-create the PDF file with a newer version of Acrobat Distiller. 

• Use the latest Adobe Postscript driver to create the PostScript file, and then re-create 
the PDF. 

Note:  

The WCAG doesn't address Unicode character mapping. 

TAGGED MULTIMEDIA 

This rule checks whether all multimedia objects are tagged. Ensure that content is included in 
the Tags tree or marked as an artifact. 

Open the Content  panel and right-click (Windows) or Ctrl-click (Mac OS) the content that 

you want to mark as an artifact. Then, select Create Artifact from the context menu. (To 

display the Content panel, select the hamburger menu  (Windows) > View or select 
the View menu (macOS), and then select Show/Hide > Side Panels > Content.) 
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Tag the content by choosing All tools > Prepare for accessibility > Reading order. Select the 
content, and then apply tags as necessary. 

Assign tags using the Tags  panel. Right-click (Windows) or Ctrl-click (Mac OS) the element 

in the Tags tree, and choose Create Tag From Selection. (To display the Tags panel, select 

the hamburger menu  (Windows) > View or select the View menu (macOS), and then 
select Show/Hide > Side Panels > Accessibility tags.) 

Note:  

See the related WCAG sections: 1.1.1 Non-text Content. (A), 1.2.1 Audio- only and Video- only 

(Prerecorded). (A), 1.2.2 Captions (Prerecorded). (A), 1.2.3 Audio Description or Media 
Alternative (Prerecorded). (A), 1.2.5 Audio Description (Prerecorded). (AA) 

SCREEN FLICKER 

Elements that make the screen flicker, such as animations and scripts, can cause seizures in 

individuals who have photosensitive epilepsy. These elements can also be difficult to see 
when the screen is magnified. 

If the Screen Flicker rule fails, manually remove or modify the script or content that causes 
screen flicker. 

Note:  

See these related WCAG sections: 1.1.1 Non-text Content. (A), 1.2.1 Audio- only and Video- 
only (Prerecorded). (A), 1.2.2 Captions (Prerecorded). (A), 1.2.3 Audio Description or Media 

Alternative (Prerecorded). (A), 2.3.1 Three Flashes or Below Threshold. (Level A) 

SCRIPTS 

Content cannot be script-dependent unless both content and functionality are accessible to 

assistive technologies. Make sure that scripting doesn't interfere with keyboard navigation or 

prevent the use of any input device. 

Check the scripts manually. Remove or modify any script or content that compromises 
accessibility. 

Note:  

See these related WCAG sections: 1.1.1 Non-text Content. (A), 2.2.2 Pause, Stop, Hide. (Level 

A), 4.1.2 Name, role, value 

TIMED RESPONSES 

This rule check applies to documents that contain forms with JavaScript. If the rule check 

fails, make sure that the page does not require timed responses. Edit or remove scripts that 
impose timely user response so that users have enough time to read and use the content. 

Note:  
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See the related WCAG section: 2.2.1 Timing Adjustable. (Level A) 

ACCESSIBLE LINKS 

For URLs to be accessible to screen readers, they must be active links that are correctly 

tagged in the PDF. (The best way to create accessible links is with the Create Link command, 
which adds all three links that screen readers require to recognize a link.) Make sure that 

navigation links are not repetitive and that there is a way for users to skip over repetitive 
links. 

If this rule check fails, check navigation links manually and verify that the content does not 

have too many identical links. Also, provide a way for users to skip over items that appear 
multiple times. For example, if the same links appear on each page of the document, also 

include a "Skip navigation" link. 

Note:  

See the related WCAG section: 2.4.1 Bypass Blocks. (Level A) 

Forms 
TAGGED FORM FIELDS 

In an accessible PDF, all form fields are tagged and are a part of the document structure. In 

addition, you can use the tool tip form filed property to provide the user with information or 
to provide instructions. 

To tag form fields, choose All tools > Prepare for accessibility > Autotag document. 

Note:  

See the related WCAG sections: 1.3.1 Info and Relationships. (Level A), 4.1.2 Name, role, value 

FIELD DESCRIPTIONS 

For accessibility, all form fields need a text description (tool tip). 

To add a text description to a form field: 

1. Select one of the Form tools, and then right-click (Windows) or Ctrl-click (Mac OS) the 
form field. 

2. Choose Properties from the context menu. 

3. Click the General properties tab. 

4. Enter a description of the form field in the Tooltip field. 

Note:  

See the related WCAG sections: 1.3.1 Info and Relationships. (Level A), 3.3.2 Labels or 
Instructions (Level A), 4.1.2 Name, role, value 
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Alternate text 
FIGURES ALTERNATE TEXT 

Make sure that images in the document either have alternate text or are marked as artifacts. 

If this rule check fails, do one of the following: 

• Select Figures Alternate Text in the Accessibility Checker panel, and 

choose Fix from the Options  menu. Add alternate text as prompted in the Set 

Alternate Text dialog box. 

• Use the Tags panel to add alternate text for images in the PDF. 

• Open the Content  panel and right-click (Windows) or Ctrl-click (Mac OS) the 

content that you want to mark as an artifact. Then, select Create Artifact from the 

context menu. (To display the Content panel, select the hamburger 
menu  (Windows) > View or select the View menu (macOS), and then 
select Show/Hide > Side Panels > Content.) 

Note:  

See the related WCAG section: 1.1.1 Non-text Content. (A) 

NESTED ALTERNATE TEXT 

Screen readers don't read the alternate text for nested elements. Therefore, don't apply 
alternate text to nested elements. 

To remove alternate text from nested elements, do the following: 

1. Select the hamburger menu  (Windows) > View or select the View menu (macOS), 
and then select Show/Hide > Side Panels > Accessibility tags. 

2. Right-click (Windows) or Ctrl-click (Mac OS) a nested element in the Accessibility 
tags panel and choose Properties from the context menu. 

3. Remove the Alternate Text and the text to which it's applied from the Object 
Properties dialog box, then select Close. 

Note:  

See the related WCAG section: #1.1.1 Non-text Content. (A) 

ASSOCIATED WITH CONTENT 

Make sure that alternate text is always an alternate representation of content on the page. If 

an element has alternate text but does not contain any page content, there is no way to 
determine which page it is on. If the Screen Reader Option in the Reading preferences is not 
set to read the entire document, then screen readers never read the alternate text. 

1. Right-click (Windows) or Ctrl-click (Mac OS) an item to check. 
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2. Open it in the Accessibility tags panel. (To display the Accessibility tags panel, select 
the hamburger menu  (Windows) > View or select the View menu (macOS), and then 

select Show/Hide > Side Panels  > Accessibility tags.) 

3. Remove the Alternate Text from the Tags panel for any nested item that has no page 
content. 

Note:  

See the related WCAG section: 1.1.1 Non-text Content. (A) 

HIDES ANNOTATION 

Alternate text can't hide an annotation. If an annotation is nested under a parent element 

with alternate text, then screen readers don't see it. 

To remove alternate text from nested elements: 

1. Select the hamburger menu  (Windows) > View or select the View menu (macOS), 
and then select Show/Hide > Side Panels > Accessibility tags. 

2. Right-click (Windows) or Ctrl-click (Mac OS) a nested element in the Tags panel and 
choose Properties from the context menu. 

3. Remove the alternate text from the Object Properties dialog box and select OK. 

Note:  

See the related WCAG sections: 1.3.1 Info and Relationships. (Level A), 4.1.2 Name, role, value 

OTHER ELEMENTS ALTERNATE TEXT 

This report checks for content other than figures that require alternate text (such as 

multimedia, annotation, or 3D model). Make sure that alternate text is always an alternate 
representation of content on the page. If an element has alternate text but does not contain 

any page content, there is no way to determine which page it is on. If the Screen Reader 

Options in the Reading preferences is not set to read the entire document, then screen 
readers don't read the alternate text. 

1. Select the hamburger menu  (Windows) > View or select the View menu (macOS), 
and then select Show/Hide > Side Panels > Accessibility tags. 

2. Right-click (Windows) or Ctrl-click (Mac OS) a nested element in the Accessibility 

tags panel and choose Properties from the context menu. 

3. Remove the alternate text from the Object Properties dialog box and select OK. 

Note:  

See the related WCAG section: 1.1.1 Non-text Content. (A) 

Tables 
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Because table structure can be complex, it is best practice to check them for accessibility 
manually. 

ROWS 

This rule checks whether each TR in a table is a child of Table, THead, TBody, or TFoot. 

See Correct table tags with the Tags panel. 

Note:  

Related WCAG section: 1.3.1 Info and Relationships. (Level A) 

TH AND TD 

In a proper table structure, TH and TD are children of TR. 

See Correct table tags with the Tags panel. 

Note:  

See related WCAG section: #1.3.1 Info and Relationships. (Level A) 

HEADERS 

For accessibility, it's necessary that all tables in the PDF have a header. 

See Correct table tags with the Tags panel. 

Note:  

See the related WCAG section: 1.3.1 Info and Relationships. (Level A) 

REGULARITY 

To be accessible, tables must contain the same number of columns in each row, and rows in 
each column. 

See Correct table tags with the Tags panel. 

Note:  

See the related WCAG section: 1.3.1 Info and Relationships. (Level A) 

SUMMARY 

Table summaries are optional, but can improve accessibility. 

1. Select All tools > Prepare for accessibility > Reading order. 

2. Select the table by drawing a rectangle around it.  

3. In the Reading order dialog box, select Table. 

4. Right-click (Windows) or Ctrl-click (Mac OS) Table. 
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5. Click Edit Table Summary. 

6. Enter a summary and select OK. 

Note:  

See the related WCAG section: 1.3.1 Info and Relationships. (Level A) 

Lists 
LIST ITEMS 

The check reports whether each List Item (LI) is a child of List (L). When this rule check fails, 

the structure of this list is incorrect. Lists must have the following structure: A List element 
must contain List Item Elements. And, List Item Elements can only contain Label 

Elements and List Item Body Elements. 

To fix the list structure: 

1. Find the list in the Accessibility Checker panel by right-clicking (Windows) or Ctrl-
clicking (Mac OS) the failed element and choosing Show In Tags Panel. 

2. Create elements, change the types of elements, or rearrange existing elements by 
dragging them. 

Note:  

See the related WCAG section: 1.3.1 Info and Relationships. (Level A) 

LBL AND LBODY 

Lists must have the following structure: A List element must contain List Item Elements. 

And, List Item Elements can only contain Label Elements and List Item Body Elements. 
When this rule check fails, the structure of this list is incorrect. 

To fix the list structure: 

1. Find the list in the Accessibility Checker panel by right-clicking (Windows) or Ctrl-
clicking (Mac OS) the failed element and choosing Show In Tags Panel. 

2. Create elements, change the types of elements, or rearrange existing elements by 
dragging them. 

Note:  

See the related WCAG section: 1.3.1 Info and Relationships. (Level A) 

Headings 
APPROPRIATE NESTING 

This rule checks nested headings. When this check fails, headings are not nested properly. 

To fix the list structure: 
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1. Find the list in the Accessibility Checker panel by right-clicking (Windows) or Ctrl-
clicking (macOS) the failed element and choosing Show in Tags Panel. 

2. Create elements, change the types of elements, or rearrange existing elements by 
dragging them. 

Note:  

See the related WCAG section: 2.4.6 Headings and Labels. (Level AA). The order of headings is 

not required under WCAG, and is only an advisory technique. 
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