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If a picture is worth a thousand words, what's it worth 

to people who cannot see? Without words, it's easy for 

people with a visual disability to miss critical 

information or get frustrated with the experience.  

Alternative text (alt text) is descriptive text which 

conveys the meaning and context of a visual item in a 

digital setting, such as on an app or web page. When 

screen readers like Microsoft Narrator, JAWS, and 

NVDA reach content with alt text, the alt text is read 

javascript:


aloud so people can better understand what's on the 

screen. Well-written, descriptive alt text dramatically 

reduces ambiguity and improves user experience. 

This topic describes how to understand, write, and use 

effective alt text in Microsoft 365 products. 

\ 

Alt text tools in Microsoft 365 

To help you with alt text, Microsoft 365 offers the 

Accessibility checker to review relevant visual content 

for alt text and get suggestions on improving content 

accessibility, an Automatic alt text generator, and a 

manual alt text editor.  



Open the Microsoft 365 Accessibility 

Checker: 

1. On the Review tab, select Check Accessibility. 

2. In the right Accessibility pane, issues with 

accessibility appear under Inspection Results. 

3. Select any flagged issues to see recommended 

actions. 

Manually view and edit alt text, or 

approve automatic alt text:  

1. Right-click an image, chart, or other object, and 

select View Alt Text.  

Tip: On the Review tab, you can select 

the Check Accessibility drop down and 

choose Alt Text. 

2. In the Alt text pane on the right, edit or 

approve the displayed alt text (if automatically 

generated). 

3. If the image doesn't need alt text, such as a 

border, select Mark as decorative. 



Turn automatically generated alt text 

on or off:  

1. On the File tab, select Options and choose 

the Accessibility tab. 

2. Select or clear the Automatically generate alt 

text for me checkbox under Automatic Alt 

Text. 

Automatic alt text generation needs Microsoft 365 

intelligent services. To turn this on:  

1. On the File tab, select Options and 

choose General. 

2. Select Enable services under Microsoft 365 

intelligent services. 

When to use alt text? 

Images and pictures 

Make sure to convey the content and the purpose of an 

image in a concise and unambiguous manner. The alt 

text shouldn’t be longer than a sentence or two—most 



of the time a few thoughtfully selected words will do. 

Consider what is important about an image. For 

example, important context might be the setting, the 

emotions on people's faces, the colors, or the relative 

sizes. 

 

Do not repeat the surrounding textual content as alt 

text or use phrases referring to images, such as, "a 

graphic of" or "an image of." In the example below, the 

alt text is referring to the image and does not describe 

the content of the image sufficiently. 



 

 You can also add alt text as an argument to the IMAGE 

function either by using text in quotes or by using a cell 

reference that contains the text. For example, 

IMAGE("www.contoso.com/logo.jpg", "Contoso logo").  

Diagrams, flow charts, and charts 

When dealing with objects that give detailed 

information, such as an infographic, use alt text to 

provide the information conveyed in the object. 

Describing a chart as ‘A bar chart showing sales over 

time,' for example, would not be useful to a blind 

person. Try to convey the insight; for example, ‘A bar 

https://support.microsoft.com/en-us/office/image-function-7e112975-5e52-4f2a-b9da-1d913d51f5d5
https://support.microsoft.com/en-us/office/image-function-7e112975-5e52-4f2a-b9da-1d913d51f5d5


chart showing sales over time. In July, sales for brand A 

surpassed sales for brand B and kept increasing 

throughout the year.’ Alt text should also clearly 

describe the beginning point, progress, and conclusion 

of flow charts. 

 

Videos 

Videos that don't explain their content require alt text 

to describe the visual experience, even if the user hears 

music, background sounds, and speech. Alt text should 

describe the content and purpose of the video. 



Ideally, a video should contain a second audio track 

with a description of the video elements that are purely 

visual and not accessible to people with a visual 

disability. 

Tables 

The Microsoft 365 Accessibility Checker does not flag if 

a table is missing alt text. However, it is always a good 

practice to write a clear, descriptive, and concise alt text 

for a table. 

When not to use alt text? 

Decorative visual objects 

Decorative objects add visual interest but aren’t 

informative (for example, stylistic borders). People 

using screen readers hear these are decorative so they 

know they aren’t missing any important information. To 

mark a visual as decorative, select the Mark as 

decorative checkbox in the Alt Text pane. The text 

entry field becomes grayed out. 



 

Tip: If you export your document as a PDF, any visuals you have marked as decorative are 

automatically tagged as artifacts. They are then ignored by screen readers when navigating through 

PDFs.  

Slicers 

If the Microsoft 365 Accessibility Checker doesn't flag 

an object when it's missing alt text, you don't have to 

write alt text for it. A slicer is an example of such an 

object. 



How to add alt text to an 

object? 

For instructions on how to add alt text in Outlook, 

Word, Excel, and PowerPoint, go to Add alternative text 

to a shape, picture, chart, SmartArt graphic, or other 

object. 

Tips for using alt text in 

Microsoft 365 

▪ Remember to use the Microsoft 365 Accessibility 

Checker during your review process. It checks 

that all relevant visual content has alt text and 

also gives you other suggestions for improving 

the accessibility of your content, such as 

checking contrast ratios. To run the Accessibility 

Checker, on the Review tab, select Check 

Accessibility. For more info on the Accessibility 

Checker, go to Improve accessibility with the 

Accessibility Checker. 

https://support.microsoft.com/en-us/office/add-alternative-text-to-a-shape-picture-chart-smartart-graphic-or-other-object-44989b2a-903c-4d9a-b742-6a75b451c669
https://support.microsoft.com/en-us/office/add-alternative-text-to-a-shape-picture-chart-smartart-graphic-or-other-object-44989b2a-903c-4d9a-b742-6a75b451c669
https://support.microsoft.com/en-us/office/add-alternative-text-to-a-shape-picture-chart-smartart-graphic-or-other-object-44989b2a-903c-4d9a-b742-6a75b451c669
https://support.microsoft.com/en-us/office/improve-accessibility-with-the-accessibility-checker-a16f6de0-2f39-4a2b-8bd8-5ad801426c7f#PickTab=Windows
https://support.microsoft.com/en-us/office/improve-accessibility-with-the-accessibility-checker-a16f6de0-2f39-4a2b-8bd8-5ad801426c7f#PickTab=Windows


▪ Do not use a file name, duplicate text, or URLs as 

alt text. The Accessibility Checker flags these 

since they are not useful to someone with a 

visual disability. For more info, go to Rules for 

the Accessibility Checker. 

▪ If there is a group of objects that forms a 

semantic group, such as a group of photos that 

all show dogs, assign alt text for the whole 

group. If objects have been grouped together 

for formatting reasons, ungroup the objects and 

assign appropriate alt text for each object. 

Note: If you have used Microsoft 365 for a while, you might have noticed that the Alt Text pane 

used to have two fields, Title and Description. Now we use a single Description field in most of our 

apps—it has been found that having a single field is easier and less confusing for both you as the 

author and also anyone using a screen reader to consume the content. 

Automatic alt text 

In Microsoft 365, alt text can be generated 

automatically. When you insert a picture, you might see 

a bar show up at the bottom of the picture with 

automatically generated alt text. 

In Office 2019, alt text is not generated automatically 

when you insert an image. If you want to add automatic 

alt text, select the Generate a description for 

https://support.microsoft.com/en-us/office/rules-for-the-accessibility-checker-651e08f2-0fc3-4e10-aaca-74b4a67101c1
https://support.microsoft.com/en-us/office/rules-for-the-accessibility-checker-651e08f2-0fc3-4e10-aaca-74b4a67101c1


me button in the Alt Text pane. Depending on the 

content of the image, sometimes the feature gives you 

descriptive tags and sometimes you get full sentences. 

If automatic alt text is generated, remember to review 

and edit it in the Alt Text pane and remove any 

comments added there such as "Description generated 

with high confidence." 

 

Turn automatic alt text on 

Note: Before you can use automatic alt text, you might have to enable Microsoft 365 Intelligent 

Services in any Microsoft 365 product. 

 

1. On the File tab, select Options and choose General. 

2. Select Enable services under Microsoft 365 intelligent services. 

 

For more info, refer to Connected experiences in Microsoft 365. 

1. On the File tab, select Options and 

choose Accessibility.  

https://support.microsoft.com/en-us/office/connected-experiences-in-microsoft-365-8d2c04f7-6428-4e6e-ac58-5828d4da5b7c


2. Select Automatically generate alt text for 

me under Automatic Alt Text. 

Approve automatic alt text 

1. In the  Microsoft 365 app, right-click the item to 

review and select View Alt Text. The Alt 

Text pane opens. 

2. If the alt text is satisfactory, select the Approve 

alt text checkbox. 



 

Turn automatic alt text off 

1. On the File tab, select Options and 

choose Accessibility.  

2. Clear Automatically generate alt text for 

me under Automatic Alt Text. 



Where to find alt text 

functional guidelines 

Get additional resources to help you write effective alt 

text: 

▪ Improve accessibility with the Accessibility 

Checker 

▪ Rules for the Accessibility Checker 

▪ Make your content accessible to everyone 

▪ Make your Word documents accessible to 

people with disabilities 

▪ Make your Excel documents accessible to people 

with disabilities 

▪ Make your OneNote notebooks accessible to 

people with disabilities 

▪ Make your Outlook email accessible to people 

with disabilities 

▪ Make your PowerPoint presentations accessible 

to people with disabilities 

▪ Make your Project Online sites and projects 

accessible to people with disabilities 

▪ Make your SharePoint site accessible to people 

with disabilities 

https://support.microsoft.com/en-us/office/improve-accessibility-with-the-accessibility-checker-a16f6de0-2f39-4a2b-8bd8-5ad801426c7f#PickTab=Windows
https://support.microsoft.com/en-us/office/improve-accessibility-with-the-accessibility-checker-a16f6de0-2f39-4a2b-8bd8-5ad801426c7f#PickTab=Windows
https://support.microsoft.com/en-us/office/rules-for-the-accessibility-checker-651e08f2-0fc3-4e10-aaca-74b4a67101c1
https://support.microsoft.com/en-us/office/make-your-content-accessible-to-everyone-ecab0fcf-d143-4fe8-a2ff-6cd596bddc6d
https://support.microsoft.com/en-us/office/make-your-word-documents-accessible-to-people-with-disabilities-d9bf3683-87ac-47ea-b91a-78dcacb3c66d#PickTab=Windows
https://support.microsoft.com/en-us/office/make-your-word-documents-accessible-to-people-with-disabilities-d9bf3683-87ac-47ea-b91a-78dcacb3c66d#PickTab=Windows
https://support.microsoft.com/en-us/office/make-your-excel-documents-accessible-to-people-with-disabilities-6cc05fc5-1314-48b5-8eb3-683e49b3e593#PickTab=Windows
https://support.microsoft.com/en-us/office/make-your-excel-documents-accessible-to-people-with-disabilities-6cc05fc5-1314-48b5-8eb3-683e49b3e593#PickTab=Windows
https://support.microsoft.com/en-us/office/make-your-onenote-notebooks-accessible-to-people-with-disabilities-3c82a6cf-17aa-4e8b-bb2b-7ce210855616#PickTab=Windows
https://support.microsoft.com/en-us/office/make-your-onenote-notebooks-accessible-to-people-with-disabilities-3c82a6cf-17aa-4e8b-bb2b-7ce210855616#PickTab=Windows
https://support.microsoft.com/en-us/office/make-your-outlook-email-accessible-to-people-with-disabilities-71ce71f4-7b15-4b7a-a2e3-cf91721bbacb#picktab=windows
https://support.microsoft.com/en-us/office/make-your-outlook-email-accessible-to-people-with-disabilities-71ce71f4-7b15-4b7a-a2e3-cf91721bbacb#picktab=windows
https://support.microsoft.com/en-us/office/make-your-powerpoint-presentations-accessible-to-people-with-disabilities-6f7772b2-2f33-4bd2-8ca7-dae3b2b3ef25#PickTab=Windows
https://support.microsoft.com/en-us/office/make-your-powerpoint-presentations-accessible-to-people-with-disabilities-6f7772b2-2f33-4bd2-8ca7-dae3b2b3ef25#PickTab=Windows
https://support.microsoft.com/en-us/office/make-your-project-online-sites-and-projects-accessible-to-people-with-disabilities-3d3e560a-4839-4677-9f6f-5ae2a2f25a88
https://support.microsoft.com/en-us/office/make-your-project-online-sites-and-projects-accessible-to-people-with-disabilities-3d3e560a-4839-4677-9f6f-5ae2a2f25a88
https://support.microsoft.com/en-us/office/make-your-sharepoint-site-accessible-to-people-with-disabilities-53707eb5-b7b8-4ee0-ae82-9d4d916f7fe1#picktab=Online_Modern_Experience
https://support.microsoft.com/en-us/office/make-your-sharepoint-site-accessible-to-people-with-disabilities-53707eb5-b7b8-4ee0-ae82-9d4d916f7fe1#picktab=Online_Modern_Experience


▪ Make your Sway design accessible to people 

with disabilities 

▪ Make your Visio diagram accessible to people 

with disabilities 

▪ For more information on how to ensure that 

Microsoft 365 products and user experiences 

meet the requirements for accessibility, visit our 

accessibility sites An inclusive, accessible 

Microsoft 365 and Make your content accessible 

to everyone with the Accessibility Checker. 

 

https://support.microsoft.com/en-us/office/make-your-sway-design-accessible-to-people-with-disabilities-c8d9638b-bd09-446f-80a5-234af71e42d9
https://support.microsoft.com/en-us/office/make-your-sway-design-accessible-to-people-with-disabilities-c8d9638b-bd09-446f-80a5-234af71e42d9
https://support.microsoft.com/en-us/office/make-your-visio-diagram-accessible-to-people-with-disabilities-e2c847a9-f010-4fef-af65-16e252829d44#PickTab=Windows
https://support.microsoft.com/en-us/office/make-your-visio-diagram-accessible-to-people-with-disabilities-e2c847a9-f010-4fef-af65-16e252829d44#PickTab=Windows
https://aka.ms/AA3k0em
https://aka.ms/AA3k0em
https://support.microsoft.com/en-us/office/make-your-content-accessible-to-everyone-with-the-accessibility-checker-38059c2d-45ef-4830-9797-618f0e96f3ab
https://support.microsoft.com/en-us/office/make-your-content-accessible-to-everyone-with-the-accessibility-checker-38059c2d-45ef-4830-9797-618f0e96f3ab

